Fix JSP compilation error in WildFly 8 using Java 8

My current project run on WildFly 8 using Java 7. I was assigned the task of migrating the existing project to work on Java 8. So my first target was to install Java 8. After installing Java 8 my next target was to deploy my project in WildFly 8 and start the server. Everything went fine until i got stuck at JSP compilation error. In this article we would learn how we can fix the JSP compilation error in WildFly 8 using Java 8.

Whenever any exception comes it always gives an scary feeling to any developers but thanks to JBoss forum i was able to fix the problem. Below are some of the errors that i got while running my project using Java 8.

This error got fixed in WildFly 8.0.1 but for those who want to manually fix this error in Wildfly 8.0, they need to follow the below steps.

Step 1:
Download JDT core compiler from http://search.maven.org/remotecontent?filepath=org/eclipse/jdt/core/compiler/ecj/4.3.1/ecj-4.3.1.jar

Step 2:
Copy the above downloaded jar package to WILDFLY_HOME/modules/system/layers/base/io/undertow/jsp/main folder

Step 3:
Modify module.xml to look as below.

Reference Url: https://developer.jboss.org/thread/238278

Tagged . Bookmark the permalink.

Comments are closed.